You are here

GENESIS 1.4.0 for LX with GPU support

Webpage

https://www.r-ccs.riken.jp/labs/cbrt/

Version

1.4.0

Build Environment

  • Intel Parallel Studio XE 2018 Update 4
  • CUDA 9.1

Files Required

  • genesis-1.4.0.tar.bz2
  • tests-1.4.0.tar.bz2

Build Procedure

#!/bin/sh

VERSION=1.4.0
BASEDIR=/home/users/${USER}/Software/GENESIS/${VERSION}
SRC_TARBALL=${BASEDIR}/genesis-${VERSION}.tar.bz2
TESTS_TARBALL=${BASEDIR}/tests-${VERSION}.tar.bz2

INSTALLDIR=/local/apl/lx/genesis140-CUDA

WORKDIR=/work/users/${USER}
BUILDDIR=${WORKDIR}/genesis-${VERSION}
TESTSDIR=${WORKDIR}/tests-${VERSION}

PARALLEL=12
PARALLEL_TESTS=8

# ----------------------------------------------------------------------------
umask 0022

module purge
module load intel_parallelstudio/2018update4
module load cuda/9.1

export LANG=C
export LC_ALL=C
export OMP_NUM_THREADS=1

cd ${WORKDIR}
if [ -d genesis-${VERSION} ]; then
  mv genesis-${VERSION} genesis-erase
  rm -rf genesis-erase &
fi

if [ -d tests-${VERSION} ]; then
  mv tests-${VERSION} tests-erase
  rm -rf tests-erase &
fi

tar jxf ${SRC_TARBALL}
tar jxf ${TESTS_TARBALL}

cd ${BUILDDIR}
FC=mpiifort CC=mpiicc \
    ./configure --prefix=${INSTALLDIR} \
                --enable-gpu \
                --enable-single \
                --with-cuda=/local/apl/lx/cuda-9.1

make depend
make -j ${PARALLEL} && make install

SPDYN=${INSTALLDIR}/bin/spdyn

cd ${TESTSDIR}/regression_test

# spdyn tests
./test.py       "mpirun -np ${PARALLEL_TESTS} $SPDYN" gpu
./test_remd.py  "mpirun -np ${PARALLEL_TESTS} $SPDYN" gpu
./test_rpath.py "mpirun -np ${PARALLEL_TESTS} $SPDYN" gpu
./test_gamd.py  "mpirun -np ${PARALLEL_TESTS} $SPDYN" gpu

Notes

  • Built and tested on ccgpuv.
    • Non-PME tests (9 of REMD tests) failed since GPU version supports only PME. This is totally expected.
    • All the other tests were passed successfully.
  • Single "spdyn" binary works both on P100 and V100 (confirmed on ccgpup and ccgpuv).
  • The build system specifies PTX and cubin versions of 35, 37, and 61. V100 (compute capability 7.0) might not be natively supported.
    • Strictly, P100 (compute capability 6.0) is not natively supported?